Juniper MX SNMP Logical-System

So it seems on a Juniper MX, SNMP on an Logical-system is not the easiest to figure out, so here was my issue I have a loopback interface configured on an logical-system with an ipv4 address. I tried to do an SNMP walk on this but kept failing all access was permitted but kept failing, after some head bashing and some assistance from a colleague we found some documentation which helped shed some light on this, ref links:

  1. Features That Are Supported on Logical Systems
  2. Identifying a Routing Instance – page 99
  3. Identifying a Routing Instance

Existing configuration of SNMP failing

So from the documentation and from what we could figure out it seems to fix this we had enable SNMP to access other routing-instances/logical-systems below is the configuration that allowed us to configure this, however when making the SNMP call we found it very Odd!! syntax see extract:

This name should be used when querying data for that routing instance (for example, LS/[email protected]). For v3 requests, the name logical system/routing instance should be identified directly in the context field.

Solution to configuring SNMP polling with Logical-Systems

1 reply
  1. Kohler
    Kohler says:

    Hi,

    If you want to access on your LS by the mgmt interface (more secure in a way …)

    delete snmp community XYZ logical-system BORDER routing-instance default
    delte snmp routing-instance-access

    And try :
    snmpwalk -v2c -c BORDER/[email protected] MGMT-INTERFACE

    Work fine on MX480 12.3
    Regards,

    Reply

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *